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Welcome 

All of us at Bradford Technologies welcome you to the ClickFORMS family. If you are evaluating ClickFORMS, 
we are here to assist you and we hope you will chose to continue using ClickFORMS to complete your future 
property valuations.  

Bradford Technologies is a privately held company exclusively dedicated to provide innovative software to 
improve appraiser efficiency. With more than 30 years of experience behind us, we are uniquely positioned 
to help appraisers meet current and future property valuation challenges.   

Purpose of this Guide 

This quick start guide is designed to get you started using ClickFORMS and serves as a how to guide for 
ClickFORMS basic functions. Other TechTip quides are also available providing more in-depth information on 
specific ClickFORMS operations.  

A list is available on this web page: https://support.bradfordsoftware.com/cf-docs 

You may either print out this guide to use as a reference or bookmark or access it from your ClickFORMS Help 
dropdown menu.  

Support and Sales Contact Information 

Our Support Team is available to assist you if you have questions or require additional instruction.  

Monday – Friday 6:00 a.m. to 6:00 p.m. PT 

Saturday & Sunday 8:00 a.m. to 3:00 p.m. PT 

Email:  

Support: support@BradfordSoftware.com 

Sales: sales@BradfordSoftware.com    

Phone: 800-622-8727

BRADFORD TECHNOLOGIES

302 Piercy Road, 

San Jose, CA 95138

http://www.bradfordsoftware.com 

https://support.bradfordsoftware.com/cf-docs
mailto:support@BradfordSoftware.com
mailto:sales@BradfordSoftware.com


3__

Updated 6/22/2020 

Table of Contents 

Intro Page ...................................................................................................................................................... 1 

Welcome ........................................................................................................................................................ 2 

Purpose of this Guide .................................................................................................................................... 2 

Support and Sales Contact Information ........................................................................................................ 2 

Table of Contents .......................................................................................................................................... 3 

Introduction ................................................................................................................................................... 4 

Starting a New Report ................................................................................................................................... 5 

Templates ...................................................................................................................................................... 7 

Address Verification ...................................................................................................................................... 8 

Adding Forms ................................................................................................................................................. 9 

Forms Manager ........................................................................................................................................... 10 

ClickFORMS Navigation ............................................................................................................................... 11 

Collapsible Pages ......................................................................................................................................... 12 

Preferences Overview ................................................................................................................................. 13 

Setting Preferences ..................................................................................................................................... 14 

Cell Preferences: .......................................................................................................................................... 17 

Cell Types ..................................................................................................................................................... 18 

Cell Formatting ............................................................................................................................................ 19 

Time Saving Features................................................................................................................................... 20 

Auto Adjustments ........................................................................................................................................ 20 

Standard Responses .................................................................................................................................... 21 

PhotoSheet and Images............................................................................................................................... 22 

Services ........................................................................................................................................................ 23 

Inserting Images, PDFs and Scanned Documents ....................................................................................... 24 

Digital Signatures ......................................................................................................................................... 25 

Edit Menu Options ...................................................................................................................................... 26 

Reviewer ...................................................................................................................................................... 28 

Report Submittal ......................................................................................................................................... 29 

Saving Prepared Files ................................................................................................................................... 29 

Help Menu ................................................................................................................................................... 30 

Reports and Comps Database ..................................................................................................................... 31 

ClickFORMS User File Folder ....................................................................................................................... 32 

Speed Keys Work Aid ................................................................................................................................... 33 

Speed Keys List ............................................................................................................................................ 34 



 

 

4__ 

Updated 6/22/2020 

 

Introduction 

Getting Started 

We know you don’t have a lot of time, so we have written this booklet to help you understand the major 

ClickFORMS functions as quickly as possible. Follow this outline and you will be using ClickFORMS for 

processing appraisals in twenty minutes or less. 

First, install the software. 

The first thing you want to do is gain an overview of what the program can do for you. Install the software 

using “ClickFORMS: How to Download and Install” Guide. 

Second, go through the tutorial. (Approximately 20 minutes) 

The tutorial will take you through the highlights of the program from “Starting a New Report” to “Getting 

Help”. After reading this Tutorial, you will know how to produce a complete appraisal report. 

Third, familiarize yourself with your Operating System. 

ClickFORMS is designed for the Windows operating system. Although the software will function on all 

Microsoft Windows operating systems Windows 7 and higher, all of the screenshots in this documentation 

were captured under a Windows 10 environment.  

Windows XP is no longer supported. Microsoft has announced that they will no longer be supporting the 

Windows 7 operating system in early 2020. 

The following is the minimum system requirements for running the ClickFORMS software: 

 Windows®  10  Operating System 

 At least 4GB of RAM, 8 or more for a new computer  

 At least 250MB of free disk space 

 At least 1280 x 800 screen resolution 

 High-speed internet connection 

 

NOTE: Apple MAC (even running Parellels ® or Boot Camp ®) is not supported 

Any of the newer processors supporting Windows 10 will work fine for ClickFORMS.  Internet speed, 

adequate RAM and a high speed hard disk or solid state drive are the most import factors to consider if you 

are buying a new computer.  

If you haven’t already, it is highly recommended that you have a process/service in place to make regular 

backups of your computer data. 

Thank you for taking the time to evaluate ClickFORMS software. - Bradford Technologies  
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Starting a New Report 

 

Start the application by clicking on the ClickFORMS program shortcut icon located on your desktop or on the 

task bar usually placed on the bottom of your monitor.  

 

A sample report form opens in the Workspace. 

 The Forms Manager listing the forms included within the report is located on the left side of the 

workspace 

 Additional forms can be found within the Forms Library 

 The Forms Library can be opened: 

o From the Forms dropdown menu  

o Clicking the Forms Library icon  

o Simultaneously press the Control Key + L keys. Just one of ClickFORMS PowerKeys 
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Experienced ClickForms appraisers will start a new report by clicking on the File dropdown menu and  

 

Options include for starting a new report 

 Report from Template: Allows for selection of either a standard template or an Appraiser’s custom 

template 

  New: Opens an empty file container allowing the appraiser to select forms from the forms library 

 Optional: Report From Address Verification: Opens the Address Verification window allowing for the 

selection of a template and entry of an address for verification of location. Note: Address verification 

option can be turned on under Startup Preferences 

 Open as a Clone:  Access a previous report and saving it with a new name. The report is filled in with 

new information.  

Notice: Cloning previously completed reports is not recommended by Bradford Technologies.  Appraisers are 

encouraged to create Templates that can be used for different types of property valuations. The 

option was added as requested by appraisers to avoid saving the modified report over the previously 

completed report. .  
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Templates 

Sample Templates are included for the most common report types.  Creating and using templates is the 

cleanest way to start new reports as opposed to cloning old reports which require a lot of cleanup or starting 

from an empty forms container.  

 

 Templates can be accessed by going to File > New > Report from Template or pressing Ctrl + N. 

 Any number of templates can be created. Once a file is created, using the Save As Template option in 

the File Menu will save the current file as a template.   

 Templates are displayed in alphabetical order.  

 To edit a template, open your Template, make changes and use the Save as Template option as 

described above.  

 Exhibit pages containing copies of your license, E&O insurance and other information you like to 

include with all your reports can be added to and saved to any template.  

 Templates can be created for specific customers as well as types of reports.  

 Previous report files can be cleaned of subject property and comp information, saved as a template 

and be used to create future valuations.   
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Address Verification 
 
This function allows for checking the property address for validity and location. 
 

 

As shown above there are many tasks that are completed on this page. The purpose of this page is to:  

 Verify the subject property address is valid  

 Correct/accept address modifications if indicated 

 Location of the subject property is accurate 

 Report template is selected 

 Desired services are selected 

 Effective date is set 

 Start the appraisal 

Notice: If there isn’t an applicable template, select the closest match. Report pages can be added from the 
forms library as needed. Unwanted forms are removed.   
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Adding Forms 

 

 The Forms Library contains all the forms available in ClickFORMS.  

 Use the Search field at the top of the box and type in the name of a specific form to locate it within 

the library.  

 You can also scroll down to a desired folder. Click on the folder and the specific forms and available 

sub-folders will be displayed. Click the folder again and it will close.  

 To add a form to your report, either double-click the form name or click and drag the form to the 

Workspace.  
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Forms Manager 

 

 The Forms Manager lists all of the forms contained within the report in the order they appear.  

 To move a form, click on it to highlight it. You can either click-hold-and-drag it to the desired location 

or you can use the up and down arrows located at the top of the Forms Manager.  

 Clicking the Trash can to the right of the arrows will remove a form from the Forms Manager.  

 Click the Forms Library Icon to the left of the arrows to open the Forms Library. 

Right click a listed form and a menu appears. You can use the functions to:  

 Duplicate a form 

 Move the form to the top or bottom 

 Move a form up and down one space at a time 

 Delete the selected form 

Note: A deleted form cannot be undone. A warning box does appear to ask, “Are you sure?”  

Notice: Form names appearing in Red in the Forms manager window have been moved to the Archive folder.    

New forms have been created to replace the archived form and added to the Forms Library.   
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ClickFORMS Navigation 

Below is a picture of the ClickFORMS window. There are many ways to navigate within a report. On this page 

we’ve documented both what you’ll see, and a few of the ways to easily move around. 

Page Title Bars Got To menu Move Field to Field 

Click on the arrows in the Page Click on the GoTo menu to  Press the Tab or Enter key to 

Title Bars to collapse or expand browse to the previous or next move to the next field. Press  

Individual pages or collapse all  page. Click the Page Navigator  Shift+Tab to return to the 

from the View Menu selection.  to view a thumbnail of all pages.  previous field 

 

 

Forms Manager Move Up and Down Scrollbars Scrollbar Arrows 

Click on any page in  Press the Up and Down Use the Scrollbars Use scrollbar arrows 

The Forms Manager  Arrow keys on your to scroll areas of your  to scroll slowly through 

To display that page  keyboard.  Report quickly into  through the report.  

in your Work-Space.  view.   
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Collapsible Pages 

 

 Page Title Bars are displayed at the top of each page in your report. 
 To expand any page in your report, click on the blue arrow. When the arrow is pointing down, the 

page is expanded  

 Click on the arrow a second time to collapse the page. When the arrow is pointing towards the right, 

the page is collapsed. To Expand or Collapse all pages, chose the View dropdown menu and select 

Expand all Pages, F3 or Collapse All Pages, Shift+F3 

 

The View dropdown menu also has selections for Expanding and Collapsing All Pages  
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Preferences Overview 

Preferences are accessed within the Edit menu. There are numerous ways you can customize ClickFORMS to 

better meet your needs.  

 

As this is your initial setup, we will focus on the most common options; these are indicated by the green 

arrows.  
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Setting Preferences  

 Startup 

 

o Click the box  for desired options  

 New users will chose to Show the Forms Library Window  

 The Address Verification window has been re-added to ClickForms and can be set to 

come up when a new template is selected 

Notice: Address verification will not work on cloned reports or reports started from an empty file container. 

• Saving 

 

o Click your preferred Default File Name format 

 

Continued on Next Page  
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Preference Settings (Continued) 

• Display 

 

o Set the desired window scale percent. Default is 94%. This percentage can also be adjusted 

on the ClickFORMS Tool bar as shown below:  

 
 

• Colors 

 

o Set Free Form Text to Black by clicking on the green square and selecting black. When 

completed, Click Apply.  
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Preference Settings (Continued) 

• Sketcher Preference 

 

o Select Sketcher that you have either installed or plan on installing.  

Notice: ClickFORMS does not come with a sketcher. If you need a sketcher, you may purchase one through 

ClickFORMS Sales. 1-800-622-8727 Option 1.  
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Cell Preferences: 

     

     

The Cells Preferences dialogue box for a cell can be accessed from the Cells menu or by right clicking on the 

cell and selecting Cell Preferences.  

 General Preferences: This is where you can change calculation, display and transfer settings for each 

cell.  

 Numbers: You can round off any number automatically, set decimals or commas and display zeros, if 

necessary.  

 Dates: Display your dates in any format.  

 Graphics: Control the way your graphics are displayed framed and fit to the cell.  
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Cell Types  

 Standard Cells   Comments Cells 

  These are single line fields.  Data you enter   These are multi-line fields that usually require 

  In these fields will transfer to every form  a description or explanation from the appraiser. 

  That has this same field. 

 

 

 Check Boxes  Number Cell    

 One of the easiest ways to make   Only numeric values are    

 a selection is to click on a check   allowed in these types of   

 box to select it.  cells.  
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Cell Formatting  

You can set the particular display, behavior or page formatting of individual fields.  Use the commands in the 

center of the Cell Menu to set any cell’s style justification and font size.  

 

 

 

Cell Formatting Toolbar Shortcuts    

 

You can click on the corresponding Toolbar icons to set the active cell’s style, font size and justification.  

 

Cut, Copy, Paste and Clear Cell Text 

 
 

 First select the text you’d like to edit by highlighting it, and then you can right click the highlighted 

area and select the desired function.  

 You may also save the highlighted text as a comment for future use.  

To eliminate one mouse-click, use the short cut keys on the task bar  
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Time Saving Features 

ClickFORMS has many time saving features that allow you to reduce the time needed to enter information 

into your report. Here are a couple of the biggest time savers.  

Auto Adjustments 

• To display this dialog box, go to the Edit menu and select Edit Adjustments 

• Single Use Adjustments: Select which adjustment you want to activate and set the Automatic 

Adjustment criteria and click on the APPLY button.  

• Permanent Adjustments: Complete the Automatic Adjustment criteria for all the adjustments you 

generally make. Click on the Save List As button to store the list for future reports.  

• To set a default adjustments list, click the box in front of Use these adjustment values in new reports.   
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Standard Responses 

All standard fields allow you to save response for future use. Some industry standard 

responses come pre-installed with your copy of ClickFORMS.  

 

 To save a response, type the response you would like to save and then press Ctrl + F2 or go to Cells > 

Save As Response 

 To view your saved responses for that field, right click on your mouse or press F2 on your keyboard. 

 To Edit a response, click on the cell that has the response you want to edit, then press Shift + F2 or go 

to Cells > Edit Responses 

Standard Comments 

 

 To save a comment, type the comment you would like to save and then press Ctrl + F2 or go to Cells > 

Save Comment. You can then give your comment a name and select Add to List.  

  To view your saved comments, right click on your mouse or press F2 to select from your list of saved 

comments. 

 To Edit a comment, click on the cell that has the comment you want to edit, then press Shift + F2 or 

go to Cells > Edit Comment 
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PhotoSheet and Images 

Adding photos, maps and scanned documents is now faster and easier to perform.  
 

 

 Add any number of photos of any size to your photo cells using the PhotoSheet tool. Located in the 

Tools menu.  

 

 Drag and drop a photo from the PhotoSheet directly into the image cell.  
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Services 

 

 You can access a number of services that are either included or available at an additional cost. Many 

services are included with the ClickFORMS Gold and Platinum subscriptions. Ask your sales 

representative about adding services to your subscription.  

 

 You can design and scale your location maps with the included mapping program.  
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Inserting Images, PDFs and Scanned Documents 

       

 In the Insert menu or right clicking a photo or exhibit cell provides for a number of options including 

inserting from PDF, form File or from a Device such as camera or scanner. 

You can insert scanned documents into exhibit pages by using the Insert from PDF file option located in the 

Insert menu.  

 

 Select a PDF and the option page above is displayed. ClickFORMS will automatically add the specified 

exhibit page style into your report.  

 One, all or a selection of pages can be inserted with one operation 

 Exhibit Titles are entered as part of the insertion process.  
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Digital Signatures 

Before you can sign a report, you need an image of your signature. You can use a scanner to scan and crop 

your signature picture. 

 If you want a colored signature, make sure you scan the colored document scanner setting. 

 We recommended using Sharpie or other broad point pen when making your signature.. 

 To insure a straight signature on your forms, sign straight across the paper 

 Making your signature a bit larger will make it more legible when it is reduced in size within the 

signature setup.  

 Once you have the image on the page, be sure to crop excess white space.  

 Save the image as a .jpg, picture file. 

Setup your digital signature 

 

 To setup the signature within ClickFORMS, access the Signatures option in the Tools menu 

 Click Setup and then load the signature file.  

 Click and drag your signature to the signature line. Use the scaling tool on the left of your signature to 

scale the size of your signature.  

 Press Ok to save.  
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Edit Menu Options 

After creating or editing a report, you can save it to any media, network server, hard disk drive or the cloud.  

 

 New: Provides for opening a new report as an open container or from a template.  

 Open: Access a previously saved file. Options include; open from Dropbox, Open as Clone and Open 

Recent 

 Close: Closes a file. You will be prompted if the file has not been saved.  

 Save: If you have an existing report file and wish to save changes to it, select the Save option or press 

the CTRL+S keys. If you do not have an easing file, you will first be asked to create and name the file.  

 Save As: A convenient option for saving multiple copies or revisions of the same report.  

 Save As Template: Create a report holder with the forms and exhibits you would like to include within 

a specific report type. Fill in repetitive information and other customizations. Save as template is an 

easy way to create a library of templates of various report types or for specific customers.  
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Edit Menu Options Continued 

 

 Save to Dropbox: Provides for saving files to a Dropbox folder. Dropbox is a cloud file storage service 

you can subscribe to in addition to ClickFORMS.  

 Create Adobe PDF. Various options allow for securing your PDF file.  

 Deliver UAD report. Provides for various submittal options for XML and ENV files. Various portal 

options are available.  

 Print: Provides for the selection and printing of your report pages.  

 Export To: Used by tech support for the creation of a file that can be reimported into ClickFORMS. 

Sometimes used for a report with unresolvable issue.  

 Import From: Provides for importing information into ClickFORMS. Options Include: Outside Vendor 

Property Data, ClickFORMS Text File, Data Import Wizard (MLS Data), Mismo XML file.  

 Merge Files: Combine two report files into one report file.  

 Convert Mismo XMLs to CLK: Allows for converting multiple UAD XML files into ClickFORMS files in 

one operation.  
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Reviewer 

The review works similar to the review that is completed during the submittal process. As the review takes 

place just before submittal, the reviewer allows the appraiser to check the report before starting the multi-

step submittal process. The same instructions apply to both review applications 

 

 The Reviewer function is located in the Tools menu. 

 Before you submit your report you can use the reviewer to check for errors within your report.  

 The appraiser has the option of selecting the pages to be reviewed by placing a checkmark in front of 

the form listed within the box.  

 There are three types of errors identified for appraiser consideration.  

 Warnings   Advised of an unexpected entry 

 Critical Warnings  Notified that a cell’s  information does not appear to be in compliance 

 Critical Errors  Must be changed in order to submit the report.  
 If possible, move the Review clear of the report page view to speed up the review process 

 Double clicking on an error moves the cursor to the applicable cell. The review window remains 

accessible. This provides the appraiser the opportunity to evaluate and make any desired changes.  

 Clicking the ReReview button creates an updated list of warnings.  

Notice: The appraiser is responsible for the contents of the report. There is no guarantee the reviewer will 

find all errors.  
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Report Submittal 

There are numerous ways to submit reports. The following information provides a general overview.  

 

 Numerous portals are supported within ClickFORMS 

 XML, ENV and PDF files can also be created and submitted through a web page or attached to an 

email message.  

 Once an option is selected, the appraiser is walked through the process.  

Saving Prepared Files 

 
 At the end of the file submittal process, the above window provides for saving the files to the default 

location within the ClickFORMS folder. 

 The Save As button is used to change the location for saving the file. 

 The Save all files is used to save all files to one location.  

 The Browse button is used to change the location where the files will be saved. 

 The Save All button is used to save files to the locations shown 

Notice: Due to the numerous email programs available, the button to Email Saved Files may not work for 

most appraisers.  
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Help Menu 

Assistance is available to you through the Help dropdown menu.  

 

 User Guides: Takes you to the guides web page on the www.Bradfordsoftware.com website 

 Support Website: Takes you to the support web page on the same website 

 Check For Updates: Verify you are running the latest version of ClickFORMS and will download 

available update for installation on your computer.  

 News: Accesses current ClickFORMS NewsDesk window.  

 Email Technical Support: An internal process that sends an email to the support inbox with your 

question. Your contact information is included from your registration file. The inbox is continuously 

monitored during working hours.  

 Send Suggestion: Works the same way as sending an Email to Technical Support.  

 Remote Support: Links you to GoTO Assist. GoTo Assist is a web based program used by the Support 

Team to access your computer under your supervision.  

 Registration: Contains your address, email address, license/certification information that is used by 

you as you create reports. Your email address and password provides access to the services you have 

purchased.  

 AppraisalWorld: Is a link to the www.AppraisalWorld.com website. Use your email and password to 

access your My Office account on the website.  

 About ClickFORMS: Displays a banner with ClickFORMS version information. Support may ask you to 

check this location to verify you have the most current version of ClickFORMS installed on your 

computer.  

  

http://www.bradfordsoftware.com/
http://www.appraisalworld.com/
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Reports and Comps Database  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 The Lists menu accesses the built in Databases. There is a Client, Report, Neighborhood and 

Comparables database.  

 The Reports Database is built by adding each report you create to the database 

 The Comparables Database is built by adding the comparable used within your reports. 

 During report file submittal, you will have the option to check the consistency of the comparables 

used with past uses of the same property. Inconsistencies will be indicated.  

 

 

 

 

 

 

 

 

 

 

 

 

 The Reports and Comparables Database options can be set within the Startup section of Preferences 

located under the Edit dropdown menu. The options are self-explanatory.   
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ClickFORMS User File Folder 

ClickFORMS keeps all the program files separate from the files that are created by you and are connected to 

your account. Updating or removing the ClickFORMS program will not involve your ClickFORMS folder stored 

under the Documents Library as shown below:  

 

Important folder for you to know in alphabetical order: 

 Databases: Contains the Reports, Comparables, Client and Neighborhood databases and related 

comparable photos 

 Digital Signature: An empty folder where you may store a copy of your digital signature 

 ENV Files: Default location for ENV file submittals 

 Inspections: Default location for storing Inspect-A-Lot inspections reports 

 PDF Files: Default location for report PDFs created during the submittal process 

 Reports: Default location of your ClickFORMS report files. Also contains a Backups folder where a 

backup of your reports is stored. 

 Responses: Stores your saved cell responses 

 Templates: Default location where template files are stored 

 UAD XML files: Default location where copies of the submitted report XML files are stored   
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Speed Keys Work Aid 

 

On the next page is a list of frequently used keyboard shortcuts.  

Below is an illustration of the Speed Keys tools you can download, cut out and place near your monitor. 

 

https://support.bradfordsoftware.com/docs/CF-PowerKey-chart.pdf  

  

https://support.bradfordsoftware.com/docs/CF-PowerKey-chart.pdf
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Speed Keys List 

 

You may want to start with this smaller list of Speed Keys. 

Copy Description To All Comps  Ctrl + = 

Copy subject description to any comp = 0 

Copy comp #1 description to subject or any comp  = 1 

Copy comp #2 description to subject or any comp  = 2 

Copy comp #3 description to subject or any comp  = 3 

Copy comp #X description to subject or any comp  = X 

Edit Comparable  Ctrl + E 

Insert Image From File  Ctrl + G 

Program Preferences  Ctrl + K 

Cell Preferences  Shift + Ctrl + I 

Show/Hide Forms Library  Ctrl + L 

Auto Display Responses  Ctrl + R 

Carryover Comments (must be in comment field)  Ctrl + Y 

Show Responses  F2 

Expand All Pages  F3 

Collapse All Pages  Shift + F3 

Show/Hide Forms Manager  F4 

Auto Adjustments  Shift + Ctrl + A 

Template List  Crtl + N 

Empty Container  Crtrl + Alt + N 

Decrease Font Size  Ctrl + [ 

Center Align Text  Ctrl + Alt + C 

Left Align Text  Ctrl + Alt + L 

Right Align Text  Ctrl + Alt + R 

Set Bold On/Off  Ctrl + B 

Set Italic On/Off  Ctrl + I 

Underline  Ctrl + U 

Insert Todays Date  Ctrl + D 

Page Navigator  Ctrl + J 

Move Courser In Any Direction  Arrow Keys 

Move Cursor From Cell to Cell  Tab or Enter 

Previous Cell  Ctrl + T 

Find and Replace  Ctrl + F 

Select All  Ctrl + A 

Copy  Ctrl + C 

Paste  Ctrl + V 

Cut  Ctrl + X 

Undo  Ctrl + Z 

Open  Ctrl + O 

Close  Ctrl + W 

Print  Ctrl + P 

Exit  Ctrl + Q 

Clear  Delete 

Save  Ctrl + S 

Save Responses Shift + F2 

Edit Reponses Shift + F2 

Cell Spell Checker Ctrl + F7 

Page Spell Checker Shift + F7 

Report Spell Checker F7 
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